const regex = /(\r\n?|\n){2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\r\\n?|\\n){2,}', 'g')
const str = `Text of example in line 1.
The text is very nice...
The end.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);