re = /(\r\n?|\n){2,}/
str = 'Text of example in line 1.
The text is very nice...
The end.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result