import Foundation
let pattern = #"(\r\n?|\n){2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Text of example in line 1.
The text is very nice...
The end.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)