use strict;
my $str = 'Text of example in line 1.
The text is very nice...
The end.';
my $regex = qr/(\r\n?|\n){2,}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";