# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{\{mul([^\} ]*) *\}\}([^\s])/{{mul$1}} $2/gm;t' <<< "{{mul|ab|ab|ab|ab|ab|ab}}
{{mul|aa|ab }}machintruc
brun}}{{mul|aa|ab}}
{{mul|fr|en|de}}[http//truc]
{{mul|fi|luo|en-gb|zh-hant }}{{chapitre|
{{mul|de|nl|fi|luo|en-gb|zh-hant }} {{lien web|
{{mr}} Trucmuche"