import Foundation
let pattern = #"\{\{mul([^\} ]*) *\}\}([^\s])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{{mul|ab|ab|ab|ab|ab|ab}}
{{mul|aa|ab }}machintruc
brun}}{{mul|aa|ab}}
{{mul|fr|en|de}}[http//truc]
{{mul|fi|luo|en-gb|zh-hant }}{{chapitre|
{{mul|de|nl|fi|luo|en-gb|zh-hant }} {{lien web|
{{mr}} Trucmuche
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{mul$1}} $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)