import re
regex = re.compile(r"\{\{mul([^\} ]*) *\}\}([^\s])", flags=re.MULTILINE)
test_str = ("{{mul|ab|ab|ab|ab|ab|ab}}\n"
"{{mul|aa|ab }}machintruc\n"
"brun}}{{mul|aa|ab}}\n"
"{{mul|fr|en|de}}[http//truc]\n"
"{{mul|fi|luo|en-gb|zh-hant }}{{chapitre|\n"
"{{mul|de|nl|fi|luo|en-gb|zh-hant }} {{lien web|\n"
"{{mr}} Trucmuche")
subst = "{{mul$1}} $2"
result = regex.sub(subst, test_str)
if result:
print(result)