// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\{\{mul([^\} ]*) *\}\}([^\s])").unwrap();
let string = "{{mul|ab|ab|ab|ab|ab|ab}}
{{mul|aa|ab }}machintruc
brun}}{{mul|aa|ab}}
{{mul|fr|en|de}}[http//truc]
{{mul|fi|luo|en-gb|zh-hant }}{{chapitre|
{{mul|de|nl|fi|luo|en-gb|zh-hant }} {{lien web|
{{mr}} Trucmuche";
let substitution = "{{mul$1}} $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}