#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:^|\G(?<!^)[^'"]*")[^"]*+(?:"[^"']*"[^"]*)*+"|\G(?<!^))[^'"]*+(')"
Local $sString = "" This is a random sentence ' with 'a quote, the quote should match"" & @CRLF & _
"" There is no quote here thats the problem" Anything here should not match but now it does: ' ." & @CRLF & _
"" Some text " some more text " this is a quote : ' that should match"" & @CRLF & _
"" When there is a quote (') here, the other one does not work : " ' and that's perfect " even if you remove the first one this : " (') " will make it work because of the greedy ( I think ) but ifyou remove those between parenthesis, the other one is matching as of now, which I do not want to happen."" & @CRLF & _
"Another example would be this one : The following should not work, but it does "This is being quoted" not this: (') " and this is also being quoted "" & @CRLF & _
""'"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")