import re
regex = re.compile(r"(?:(?:^|\G(?<!^)[^'\"]*\")[^\"]*+(?:\"[^\"']*\"[^\"]*)*+\"|\G(?<!^))[^'\"]*+(')")
test_str = ("\" This is a random sentence ' with 'a quote, the quote should match\"\n"
"\" There is no quote here thats the problem\" Anything here should not match but now it does: ' .\n"
"\" Some text \" some more text \" this is a quote : ' that should match\"\n"
"\" When there is a quote (') here, the other one does not work : \" ' and that's perfect \" even if you remove the first one this : \" (') \" will make it work because of the greedy ( I think ) but ifyou remove those between parenthesis, the other one is matching as of now, which I do not want to happen.\"\n"
"Another example would be this one : The following should not work, but it does \"This is being quoted\" not this: (') \" and this is also being quoted \"\n"
"\"'\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")