const regex = /(?:(?:^|\G(?<!^)[^'"]*")[^"]*+(?:"[^"']*"[^"]*)*+"|\G(?<!^))[^'"]*+(')/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:^|\\G(?<!^)[^\'"]*")[^"]*+(?:"[^"\']*"[^"]*)*+"|\\G(?<!^))[^\'"]*+(\')', 'g')
const str = `" This is a random sentence ' with 'a quote, the quote should match"
" There is no quote here thats the problem" Anything here should not match but now it does: ' .
" Some text " some more text " this is a quote : ' that should match"
" When there is a quote (') here, the other one does not work : " ' and that's perfect " even if you remove the first one this : " (') " will make it work because of the greedy ( I think ) but ifyou remove those between parenthesis, the other one is matching as of now, which I do not want to happen."
Another example would be this one : The following should not work, but it does "This is being quoted" not this: (') " and this is also being quoted "
"'"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}