import Foundation
let pattern = #"(?:(?:^|\G(?<!^)[^'"]*")[^"]*+(?:"[^"']*"[^"]*)*+"|\G(?<!^))[^'"]*+(')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
" This is a random sentence ' with 'a quote, the quote should match"
" There is no quote here thats the problem" Anything here should not match but now it does: ' .
" Some text " some more text " this is a quote : ' that should match"
" When there is a quote (') here, the other one does not work : " ' and that's perfect " even if you remove the first one this : " (') " will make it work because of the greedy ( I think ) but ifyou remove those between parenthesis, the other one is matching as of now, which I do not want to happen."
Another example would be this one : The following should not work, but it does "This is being quoted" not this: (') " and this is also being quoted "
"'"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)