#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[*:]|(?<!B~)[~](?![~])"
Local $sString = "ABCHKLJNKL*dskjnsdfkdsmflkmdls MLKMLKML~KMLKMLKMMML zlmlkmm:skjnjnskfjnkjsdnkfjnkdjs B~~KJNNKJNJNKKJNKJNFKKJNJNK"
Local $sSubst = "@"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)