re = /[*:]|(?<!B~)[~](?![~])/m
str = 'ABCHKLJNKL*dskjnsdfkdsmflkmdls MLKMLKML~KMLKMLKMMML zlmlkmm:skjnjnskfjnkjsdnkfjnkdjs B~~KJNNKJNJNKKJNKJNFKKJNJNK'
subst = '@'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result