use strict;
my $str = 'ABCHKLJNKL*dskjnsdfkdsmflkmdls MLKMLKML~KMLKMLKMMML zlmlkmm:skjnjnskfjnkjsdnkfjnkdjs B~~KJNNKJNJNKKJNKJNFKKJNJNK';
my $regex = qr/[*:]|(?<!B~)[~](?![~])/mp;
my $subst = '@';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";