$re = '/[*:]|(?<!B~)[~](?![~])/m';
$str = 'ABCHKLJNKL*dskjnsdfkdsmflkmdls MLKMLKML~KMLKMLKMMML zlmlkmm:skjnjnskfjnkjsdnkfjnkdjs B~~KJNNKJNJNKKJNKJNFKKJNJNK';
$subst = "@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;