import re
regex = re.compile(r"[*:]|(?<!B~)[~](?![~])", flags=re.MULTILINE)
test_str = "ABCHKLJNKL*dskjnsdfkdsmflkmdls MLKMLKML~KMLKMLKMMML zlmlkmm:skjnjnskfjnkjsdnkfjnkdjs B~~KJNNKJNJNKKJNKJNFKKJNJNK"
subst = "@"
result = regex.sub(subst, test_str)
if result:
print(result)