# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/word(?=[^>]*(?:$|<))/<newWord>/g;t' <<< "foo word <word> <foo word foo> word word <> word <word> <aibwui word iawigw word>"