use strict;
my $str = 'foo word <word> <foo word foo> word word <> word <word> <aibwui word iawigw word>';
my $regex = qr/word(?=[^>]*(?:$|<))/p;
my $subst = '<newWord>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";