import Foundation
let pattern = #"word(?=[^>]*(?:$|<))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"foo word <word> <foo word foo> word word <> word <word> <aibwui word iawigw word>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<newWord>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)