import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "word(?=[^>]*(?:$|<))";
final String string = "foo word <word> <foo word foo> word word <> word <word> <aibwui word iawigw word>";
final String subst = "<newWord>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}