using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"word(?=[^>]*(?:$|<))";
string substitution = @"<newWord>";
string input = @"foo word <word> <foo word foo> word word <> word <word> <aibwui word iawigw word>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}