using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)LOC\s+\[(?<LOC>[^\]]+).*Channel:\s+(?<Channel>.*)\s+offset\s+level:\s+(?<offset>.*)";
string input = @"035: Aug 17, 2021 6:45:33 TYPE: LOC [+46.2 degC]
-0.3200 ddm [ 90 Hz pred] 90Hz: 35.15 %mod 150Hz: 3.15 %mod
Channel: 110.50 MHz -4.84 KHz offset level: -61.0 dBm
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}