import Foundation
let pattern = #"(?ms)LOC\s+\[(?<LOC>[^\]]+).*Channel:\s+(?<Channel>.*)\s+offset\s+level:\s+(?<offset>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
035: Aug 17, 2021 6:45:33 TYPE: LOC [+46.2 degC]
-0.3200 ddm [ 90 Hz pred] 90Hz: 35.15 %mod 150Hz: 3.15 %mod
Channel: 110.50 MHz -4.84 KHz offset level: -61.0 dBm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)