$re = '/(?ms)LOC\s+\[(?<LOC>[^\]]+).*Channel:\s+(?<Channel>.*)\s+offset\s+level:\s+(?<offset>.*)/m';
$str = '035: Aug 17, 2021 6:45:33 TYPE: LOC [+46.2 degC]
-0.3200 ddm [ 90 Hz pred] 90Hz: 35.15 %mod 150Hz: 3.15 %mod
Channel: 110.50 MHz -4.84 KHz offset level: -61.0 dBm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);