// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?ms)LOC\s+\[(?<LOC>[^\]]+).*Channel:\s+(?<Channel>.*)\s+offset\s+level:\s+(?<offset>.*)").unwrap();
let string = "035: Aug 17, 2021 6:45:33 TYPE: LOC [+46.2 degC]
-0.3200 ddm [ 90 Hz pred] 90Hz: 35.15 %mod 150Hz: 3.15 %mod
Channel: 110.50 MHz -4.84 KHz offset level: -61.0 dBm
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}