import re
regex = re.compile(r"(?ms)LOC\s+\[(?<LOC>[^\]]+).*Channel:\s+(?<Channel>.*)\s+offset\s+level:\s+(?<offset>.*)", flags=re.MULTILINE)
test_str = ("035: Aug 17, 2021 6:45:33 TYPE: LOC [+46.2 degC]\n"
"-0.3200 ddm [ 90 Hz pred] 90Hz: 35.15 %mod 150Hz: 3.15 %mod\n"
"Channel: 110.50 MHz -4.84 KHz offset level: -61.0 dBm\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")