#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)".{11,}""
Local $sString = ""hi"" & @CRLF & _
""hello"" & @CRLF & _
""something"" & @CRLF & _
""somethingsomething"" & @CRLF & _
""1234567890"" & @CRLF & _
""12345678901"" & @CRLF & _
"hi" & @CRLF & _
"hello" & @CRLF & _
"something" & @CRLF & _
"1234567890" & @CRLF & _
"12345678901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")