re = /".{11,}"/m
str = '"hi"
"hello"
"something"
"somethingsomething"
"1234567890"
"12345678901"
hi
hello
something
1234567890
12345678901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end