const regex = /".{11,}"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('".{11,}"', 'gm')
const str = `"hi"
"hello"
"something"
"somethingsomething"
"1234567890"
"12345678901"
hi
hello
something
1234567890
12345678901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}