#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:http://|https://)?(?:www\.)?cfx\.re/join/[a-z0-9:]{6}$"
Local $sString = "cfx.re/join/98e8ob" & @CRLF & _
"http://cfx.re/join/ydpmy9" & @CRLF & _
"https://cfx.re/join/bkomed" & @CRLF & _
"cfx.re/join/98e8oB" & @CRLF & _
"cfx.re/join/98e8obb" & @CRLF & _
"cfx.re/join/98e8o"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")