package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:http://|https://)?(?:www\.)?cfx\.re/join/[a-z0-9:]{6}$`)
var str = `cfx.re/join/98e8ob
http://cfx.re/join/ydpmy9
https://cfx.re/join/bkomed
cfx.re/join/98e8oB
cfx.re/join/98e8obb
cfx.re/join/98e8o`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}