re = /(?:http:\/\/|https:\/\/)?(?:www\.)?cfx\.re\/join\/[a-z0-9:]{6}$/m
str = 'cfx.re/join/98e8ob
http://cfx.re/join/ydpmy9
https://cfx.re/join/bkomed
cfx.re/join/98e8oB
cfx.re/join/98e8obb
cfx.re/join/98e8o'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end