import re
regex = re.compile(r"(?:http://|https://)?(?:www\.)?cfx\.re/join/[a-z0-9:]{6}$", flags=re.MULTILINE)
test_str = ("cfx.re/join/98e8ob\n"
"http://cfx.re/join/ydpmy9\n"
"https://cfx.re/join/bkomed\n"
"cfx.re/join/98e8oB\n"
"cfx.re/join/98e8obb\n"
"cfx.re/join/98e8o")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")