using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http://|https://)?(?:www\.)?cfx\.re/join/[a-z0-9:]{6}$";
string input = @"cfx.re/join/98e8ob
http://cfx.re/join/ydpmy9
https://cfx.re/join/bkomed
cfx.re/join/98e8oB
cfx.re/join/98e8obb
cfx.re/join/98e8o";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}