# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(\S+)(?:\s+\1)+/$1/gm;t' <<< "hello me now @@@ @@@ @@@ then method me @@@"