use strict;
my $str = 'hello me now @@@ @@@ @@@ then method me @@@';
my $regex = qr/(?<!\S)(\S+)(?:\s+\1)+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";