re = /(?<!\S)(\S+)(?:\s+\1)+/m
str = 'hello me now @@@ @@@ @@@ then method me @@@'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result