using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(\S+)(?:\s+\1)+";
string substitution = @"$1";
string input = @"hello me now @@@ @@@ @@@ then method me @@@";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}