const regex = /(?<!\S)(\S+)(?:\s+\1)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(\\S+)(?:\\s+\\1)+', 'gm')
const str = `hello me now @@@ @@@ @@@ then method me @@@`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);