$re = '/(?<!\S)(\S+)(?:\s+\1)+/m';
$str = 'hello me now @@@ @@@ @@@ then method me @@@';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;