import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*[\\{\\}](?=\\h*(\\/\\/|$))(*SKIP)(*FAIL)|[\\{\\}]";
final String string = "//DO NOT DELETE, needs a line here for some reason.\n"
+ "Menu \"DedicatedDemorecorder\"\n"
+ "{ // this is fine\n"
+ " Option \"❍ Start Recording\" \"beginchat /demorecord $$popmenu recorderprompt\"\n"
+ " Divider\n"
+ " Option \"❑ Stop Recording\" \"demostop\"\n"
+ "} wrong\n"
+ "// Don't know if a line is needed here actually\n"
+ "Menu \"recorderprompt\"\n"
+ "{\n"
+ " Title \"Enter recording name\"\n"
+ " LockedOption\n"
+ " {\n"
+ " DisplayName \"Input name for the recording\"\n"
+ " Command \"Command\"\n"
+ " Badge \"x\"\n"
+ " }\n"
+ " LockedOption\n"
+ " {\n"
+ " DisplayName \"into the chat box, hit ENTER\"\n"
+ " Command \"Command\"\n"
+ " Badge \"x\" }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}