const regex = /^\h*[{}](?=\h*(\/\/|$))(*SKIP)(*FAIL)|[{}]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\h*[{}](?=\\h*(\\\/\\\/|$))(*SKIP)(*FAIL)|[{}]', 'gm')
const str = `//DO NOT DELETE, needs a line here for some reason.
Menu "DedicatedDemorecorder"
{ // this is fine
Option "❍ Start Recording" "beginchat /demorecord \$\$popmenu recorderprompt"
Divider
Option "❑ Stop Recording" "demostop"
} wrong
// Don't know if a line is needed here actually
Menu "recorderprompt"
{
Title "Enter recording name"
LockedOption
{
DisplayName "Input name for the recording"
Command "Command"
Badge "x"
}
LockedOption
{
DisplayName "into the chat box, hit ENTER"
Command "Command"
Badge "x" }
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}