$re = '/^\h*[{}](?=\h*(\/\/|$))(*SKIP)(*FAIL)|[{}]/m';
$str = '//DO NOT DELETE, needs a line here for some reason.
Menu "DedicatedDemorecorder"
{ // this is fine
Option "❍ Start Recording" "beginchat /demorecord $$popmenu recorderprompt"
Divider
Option "❑ Stop Recording" "demostop"
} wrong
// Don\'t know if a line is needed here actually
Menu "recorderprompt"
{
Title "Enter recording name"
LockedOption
{
DisplayName "Input name for the recording"
Command "Command"
Badge "x"
}
LockedOption
{
DisplayName "into the chat box, hit ENTER"
Command "Command"
Badge "x" }
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);