import Foundation
let pattern = #"^\h*[{}](?=\h*(\/\/|$))(*SKIP)(*FAIL)|[{}]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
//DO NOT DELETE, needs a line here for some reason.
Menu "DedicatedDemorecorder"
{ // this is fine
Option "❍ Start Recording" "beginchat /demorecord $$popmenu recorderprompt"
Divider
Option "❑ Stop Recording" "demostop"
} wrong
// Don't know if a line is needed here actually
Menu "recorderprompt"
{
Title "Enter recording name"
LockedOption
{
DisplayName "Input name for the recording"
Command "Command"
Badge "x"
}
LockedOption
{
DisplayName "into the chat box, hit ENTER"
Command "Command"
Badge "x" }
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)