use strict;
my $str = '//DO NOT DELETE, needs a line here for some reason.
Menu "DedicatedDemorecorder"
{ // this is fine
Option "❍ Start Recording" "beginchat /demorecord $$popmenu recorderprompt"
Divider
Option "❑ Stop Recording" "demostop"
} wrong
// Don\'t know if a line is needed here actually
Menu "recorderprompt"
{
Title "Enter recording name"
LockedOption
{
DisplayName "Input name for the recording"
Command "Command"
Badge "x"
}
LockedOption
{
DisplayName "into the chat box, hit ENTER"
Command "Command"
Badge "x" }
}';
my $regex = qr/^\h*[{}](?=\h*(\/\/|$))(*SKIP)(*FAIL)|[{}]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}