# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\h*[{}](?=\h*(\/\/|$))(*SKIP)(*FAIL)|[{}]"
test_str = ("//DO NOT DELETE, needs a line here for some reason.\n"
"Menu \"DedicatedDemorecorder\"\n"
"{ // this is fine\n"
" Option \"❍ Start Recording\" \"beginchat /demorecord $$popmenu recorderprompt\"\n"
" Divider\n"
" Option \"❑ Stop Recording\" \"demostop\"\n"
"} wrong\n"
"// Don't know if a line is needed here actually\n"
"Menu \"recorderprompt\"\n"
"{\n"
" Title \"Enter recording name\"\n"
" LockedOption\n"
" {\n"
" DisplayName \"Input name for the recording\"\n"
" Command \"Command\"\n"
" Badge \"x\"\n"
" }\n"
" LockedOption\n"
" {\n"
" DisplayName \"into the chat box, hit ENTER\"\n"
" Command \"Command\"\n"
" Badge \"x\" }\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.