#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[;#%|*].*(?:(?:\r\n|\r|\n) *[;#%|*].*)*"
Local $sString = "Single Line Comment:" & @CRLF & _
"# This is a single line comment" & @CRLF & _
"" & @CRLF & _
"Multiple Line Comment:" & @CRLF & _
"# This is a multiple line comment" & @CRLF & _
"# which is just a block of single line comments" & @CRLF & _
"# that are strung together" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")