re = /[;#%|*].*(?:(?:\r\n|\r|\n) *[;#%|*].*)*/m
str = 'Single Line Comment:
# This is a single line comment
Multiple Line Comment:
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end