$re = '/[;#%|*].*(?:(?:\r\n|\r|\n) *[;#%|*].*)*/m';
$str = 'Single Line Comment:
# This is a single line comment
Multiple Line Comment:
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);